У меня обновилась Мозилла до версии 52.0 и стала навязчиво пугать отсутствием и недействительными  сертификатами на моих  сайтах, и обнаглела до того, что даже стала препятствовать заходу в админки собственных сайтов. Мне это надоело, и я просто ее снес. И поставил старую — версию 45.0, заблокировав обновления. Что и рекомендую всем, у кого есть такая проблема. Скачать ее можно в интернете. Еще более надежный результат будет если поставить более раннюю версию, например 10.0.